Newly discovered security leak Ripple20 and MetaSystems devices

Aug 5, 2020

Lately it was discovered that many networked devices are vulnerable to remote attacks through 19 vulnerabilities. The flaws, collectively known as Ripple20, affect the TCP/IP stack. The security gaps in the TCP/IP implementation threaten household and office equipment, but also equipment in hospitals and industrial plants. Unfortunately, also PC hardware used in combination with MetaSystems devices may be affected, and problems may arise if the network settings are not configured correctly or the workstation is connected directly to the internet.

Namely, the following PC models are subject to these vulnerabilities:

  • DELL Optiplex 5040 / 5050 /5060 / 5070
  • DELL Optiplex 7040 / 7050 / 7060
  • DELL Precision P3630

Should one or more of your MetaSystems devices run on one of the above listed workstations, we encourage you to update your system(s) to the latest firmware versions at your earliest convenience., Please use the link below to download and install the respective update packages:

https://www.dell.com/support/home/en-th?app=drivers

For additional support, please contact [email protected].

Your cookie settings prevent this video from being displayed.

関連製品/ソリューション